Why!?!?

I pushed my luck and tried to get 7.10 working last night.
Many things just kinda exploded and I decided that since I hadn’t put that much into 7.04, I’d just start fresh and do a new install.

Well, to my happy surprise everything just kinda worked.
It was weird.
Sure, I still had to manually set my sound card, and I booted for the first time in safe mode(just in case) but since then have been booting in normal mode and everything was good.

A little reading, and I got the cool desktop graphics thingy working.
So all in all pretty good. It might actually stay this time.

Then I installed Cedega so that I could play COH(which I did get working).
It didn’t want to start the COH install process.
Hmmm.
So I made it do a debug log. A 2 gig debug log apparently.
One of the things that I saw was a problem with graphics driver.
Hmmm.
I ran the Cedega testing thingy(skipped it intially since everything *was* working) and it appears that it can’t run the OpenGL bit.
Hmmm.
Looking around, I see that my restricted drivers are on and working, so I turn them off, reboot, turn them on, reboot, and still no love.
Maybe the drivers are just bad and I should remove them fully and try again.
Well, it doesn’t actually do that, at least not through the package manger.
So I fumble around and find this thing that let’s me set up the graphics.
I try that. I also see that I can use the OpenSource or Proprietary driver. Well, since it’s restricted, let’s try Proprietary.
Reboot.
Linux can’t find my drivers, and I’m in uber safe mode.
I configure.
Appears that I selected vesa drivers for ATI. My bad.
Select Radion(fglrx) and reboot.
Can’t find the drivers.
Apparently I STILL selected the vesa drivers.
Try again, and reboot.
At this point it’s obvious that Linux just isn’t listening. For no matter what I choose, it still comes up with vesa drivers, and I’m stuck with 800×600 uber safe mode.

Hi, I’d like to use the Radion drivers please.
Vesa?
No, Radion.
Oh, vesa drivers.
No…no, Radion….R A
V E
No, no, wait. Radion drivers. You had them, I saw them.
Oh, those. We’re out.
But I see them right there!
Those, no, it’s just for display.
Can I have the display ones then? It’s really what I want.
No, sorry, if I gave them to you, then we wouldn’t have any for display.
But the Vesa you gave me don’t work.
Well then, you should get the Radion ones.

And so on and so forth until I just give up and restore the 7.04 that I smartly backed up.

Until I find that the backup image isn’t working…

Advertisements

2 thoughts on “Why!?!?

  1. I applaud your exploratory spirit!

    I too have falle n prey to premature reinstall fever. (Reinstallarrhea?)

    Currently I’m back on OX X 10.4.11 (I’m not even sure why, except it bugged me that I went to try it and I was flatly denied… I did find the Mac disk utility tool though…)

    Oddly I was quite happy with XP, though Ubuntu is probably one of the slickest things I’ve seen in a while.

    I think I just miss variety.

    (OS X gets another chance because I gave Vista one, and on a semi-related note, I hated meaningful whitespace in Python, but I’ve since gotten used to it… and like Python quite a bit…)

    Best of luck!

    [Don’t you love being able to move data around more freely now. I’ve got so much stored in Google bookmarks, reader, etc. that I loose nothing… then again I’m not much for MP3s, etc…]

  2. http://xkcd.org/353/

    I’m still not sure that Linux (/Ubuntu) will save us all, but at least I don’t have to piss around with WGA & other idiocy to get it working. Mind you, I’m not sure I’d still be using it if I had to put up with the crap SK is getting.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s